Mapleトップページ
製品・サービス

Maple 動作環境

Maple 2017 動作環境

最新バージョン:Maple 2017

Windows® (32-bit)

バージョン CPU 推奨メモリ量 HDD容量
Windows 10 ・ 1 GHz 以上
・ 32-bit (x86)
4GB 4GB
Windows 8.1 ・ 1 GHz 以上
・ PAE, NX, SSE2 サポート
4GB 4GB
Windows 7 ・ 1 GHz 以上
・ 32-bit (x86)
4GB 4GB
・DVD-ROM ドライブ (DVD インストール用)
・解像度 1024 x 768 で 16 ビット以上を推奨
・内部 TCP/IP 接続有効
・推奨メモリ以下の場合、パフォーマンスが低下したり、使える機能が限定されることがあります

Windows® (64-bit)

バージョン CPU 推奨メモリ量 HDD容量
Windows Server 2016 ・ 1.4 GHz 以上
・ 64-bit (x64)
4GB 4GB
Windows 10 ・ 1 GHz 以上
・ 64-bit (x64)
4GB 4GB
Windows 8.1 ・ 1 GHz 以上
・ PAE, NX, SSE2 サポート
4GB 4GB
Windows Server 2012 R2 ・ 1.4 GHz 以上
・ 64-bit (x64)
4GB 4GB
Windows 7 ・ 1 GHz 以上
・ 64-bit (x64)
4GB 4GB
・DVD-ROM ドライブ (DVD インストール用)
・解像度 1024 x 768 で 16 ビット以上を推奨
・内部 TCP/IP 接続有効
・推奨メモリ以下の場合、パフォーマンスが低下したり、使える機能が限定されることがあります
・クラシックワークシートはご利用いただけません

Mac®

バージョン CPU 推奨メモリ量 HDD容量
Mac OS 10.12, 10.11, 10.10 64-bit, Intel 4GB 4GB
・Java™ 8 Update 45 以降が必要
・Java Runtime Environment 1.6 のインストール
・DVD-ROM ドライブ (DVD インストール用)
・解像度 1024 x 768 で 16 ビット以上を推奨
・内部 TCP/IP 接続有効
・推奨メモリ以下の場合、パフォーマンスが低下したり、使える機能が限定されることがあります
・クラシックワークシートはご利用いただけません

Linux® (64-bit)

ディストリビューション CPU 推奨メモリ量 HDD容量
Red Hat Enterprise Linux 7 ・ 1 GHz 以上
・ 64-bit (x64)
4GB 4GB
SUSE Linux Enterprise Desktop 12 ・ 1 GHz 以上
・ 64-bit (x64)
4GB 4GB
Ubuntu 17.04, 16.04 LTS ・ 1 GHz 以上
・ 64-bit (x64)
4GB 4GB
・DVD-ROM ドライブ (DVD インストール用)
・解像度 1024 x 768 で 16 ビット以上を推奨
・X11 R6
・内部 TCP/IP 接続有効
・推奨メモリ以下の場合、パフォーマンスが低下したり、使える機能が限定されることがあります
・クラシックワークシートはご利用いただけません

Maple 2017の他ツールとのリンク機能

パッケージ名 他ツールバージョン
Microsoft® Excel® 2016, 2013, 2010 (Windows版)
MATLAB® 2017a, 2016b, 2016a
データベース SQLite または JDBC 準拠のデータベース
CAD SolidWorks® 2013 (Windows版)
Autodesk Inventor® 2014 または 2015 (Windows版)
NX® 8.5 または 9.0 (Windows版) + Microsoft .NET Framework

Maple 2017 アドオン製品 対応表

プロダクト名 必須ツール※
BlockImporter™ ・ Maple 2017
・ MATLAB® & Simulink® (※)
Global Optimization Toolbox Maple 2017
Maple Player Maple本体は不要
Maple Player for iPad ・ iPad (iOS v4.3 以上)
・ Maple本体は不要

各アドオン製品の基本的な動作環境は Maple 2017 本体に準拠します。
※ MATLAB® 2014b / Simulink® 8.4
  MATLAB® 2015a / Simulink® 8.5
  MATLAB® 2015b / Simulink® 8.6

Maple 2017共通の注意点について

  • Windows版とMacintosh版のみ日本語環境を提供しております。Linux版は英語環境での提供です。
  • 最小構成でご利用される場合はクラシックワークシートインターフェイスが推奨です。
  • Mapleは実行中、内部でTCP/IPを使用します。従ってファイアウォールや同等の動作を行うソフトウェア(例:ウイルス対策ソフト等)を使用している場合、別途設定を行う必要があります。
  • 64bit版のWindowsをご利用の場合、Maple用のコンパイラを別途インストールする必要があります。Microsoft Visual Studio C++ 2013 および 2015 コンパイラがサポートされます。
  • 2D MathをMapleViewerでHTMLに出力する場合、出力されるHTMLを閲覧するため、下記が必要となります。
ご不明な点や詳細について、また上記リストに記載の無い動作環境につきましては、
テクニカルサポートへお問い合わせください。

Maple 2016 動作環境

最新バージョン:Maple 2016

Windows

バージョン CPU 推奨メモリ量(※1) HDD容量
32-bit Windows 7 ・ 1 GHz 以上
・ 32-bit (x86)
4GB 4GB
32-bit Windows 8.1 ・ 1 GHz 以上
・ PAE, NX, SSE2 サポート
32-bit Windows 10 ・ 1 GHz 以上
・ 32-bit (x86)
64-bit Windows 7 ・ 1 GHz 以上
・ 64-bit (x64)
64-bit Windows 8.1 ・ 1 GHz 以上
・ PAE, NX, SSE2 サポート
64-bit Windows 10 ・ 1 GHz 以上
・ 64-bit (x64)
64-bit Windows Server (2008 R2, 2012) ・ 1.4 GHz 以上
・ 64-bit (x64)

Macintosh

CPU バージョン 推奨メモリ量(※1) HDD容量
64-bit Intel OS X 10.9, 10.10, 10.11 4GB 4GB

※1 Java 8 Update 45 以降が必要です。
※2 Java Runtime Environment 1.6

Linux

ディストリビューション バージョン CPU 推奨メモリ量(※1) HDD容量
64-bit Red Hat Enterprise 6, 7 ・ 1 GHz 以上
・ 64-bit (x64)
4GB 4GB
64-bit SUSE 11, 12
64-bit Ubuntu 14.04 LTS, 15.10

Maple 2016の他ツールとのリンク機能

パッケージ名 他ツールバージョン
Microsoft® Excel® 2007, 2010, 2013 (Windows版) ※
MATLAB® R2014b / R2015a / R2015b
データベース SQLite または JDBC 準拠のデータベース
CAD SolidWorks® 2013 (Windows版)
Autodesk Inventor® 2014 または 2015 (Windows版)
NX® 8.5 または 9.0 (Windows版) + Microsoft .NET Framework

※Microsoft Excel 2007は32-bitアプリケーションのみ対応可能です。従って、Excel add-inを使用する為、32-bit Windows 版の Mapleをインストールする必要があります。64-bit Windows 版 Maple の場合は、Excel 2010 や Excel 2013 の Excel add-inのみ使用できます。

Maple 2016 アドオン製品 対応表

プロダクト名 必須ツール※
BlockImporter™ ・ Maple 2015
・ MATLAB® & Simulink® (※)
Global Optimization Toolbox Maple 2015
※Maple 2016 対応は、近日を予定しています。
Maple IDE Maple 18 または Maple 2015 対応
Maple Player Maple本体は不要
Maple Player for iPad ・ iPad (iOS v4.3 以上)
・ Maple本体は不要

各アドオン製品の基本的な動作環境は Maple 2016 本体に準拠します。
※ MATLAB® 2014b / Simulink® 8.4
  MATLAB® 2015a / Simulink® 8.5
  MATLAB® 2015b / Simulink® 8.6

Maple 2016共通の注意点について

  • ※1 推奨メモリ以下でご利用になる場合、パフォーマンスが低下したり、使える機能が限定されることがあります。最小構成でご利用される場合はクラシックワークシートインターフェイスが推奨です。
  • DVD でインストールする際には、DVD-ROMドライブが必要です。
  • Mapleは実行中、内部でTCP/IPを使用します。従ってファイアウォールや同等の動作を行うソフトウェア(例:ウイルス対策ソフト等)を使用している場合、別途設定を行う必要があります。
  • Windows版とMacintosh版のみ日本語環境を提供しております。Linux版は英語環境でのみ提供しております。
  • 64bit版のWindowsをご利用の場合、Maple用のコンパイラを別途インストールする必要があります。Microsoft Visual Studio C++ 2013 および 2015 コンパイラがサポートされます。
  • クラシックワークシートはWindows 32bit, Linux 32bit OSでのみサポートされます。
  • 画面の設定について、画面の色を16-bit以上、画面の解像度を1024x768以上が推奨です。
  • 2D MathをMapleViewerでHTMLに出力する場合、出力されるHTMLを閲覧するため、下記が必要となります。
    • Java Runtime Environment 1.6.0_18 以降。
ご不明な点や詳細について、また上記リストに記載の無い動作環境につきましては、
テクニカルサポートへお問い合わせください。

Maple 2015 動作環境

最新バージョン:Maple 2015.2a(Windows, Linux)/ Maple 2015.2 (Mac)

Windows

バージョン CPU 推奨メモリ量(※1) HDD容量
32-bit Windows 7 ・ 1 GHz 以上
・ 32-bit (x86)
4GB 4GB
32-bit Windows 8.1 ・ 1 GHz 以上
・ PAE, NX, SSE2 サポート
32-bit Windows 10 ・ 1 GHz 以上
・ 32-bit (x86)
64-bit Windows 7 ・ 1 GHz 以上
・ 64-bit (x64)
64-bit Windows 8.1 ・ 1 GHz 以上
・ PAE, NX, SSE2 サポート
64-bit Windows 10 ・ 1 GHz 以上
・ 64-bit (x64)
64-bit Windows Server (2008 R2, 2012) ・ 1.4 GHz 以上
・ 64-bit (x64)

Macintosh

CPU バージョン 推奨メモリ量(※1) HDD容量
64-bit Intel OS X 10.8, 10.9, 10.10, 10.11(※2) 4GB 4GB

※1 Java 8 Update 45 以降が必要です。
※2 Mac OS X 10.11では Maple2015.2 (またはそれ以降)が必要です。

Linux

ディストリビューション バージョン CPU 推奨メモリ量(※1) HDD容量
32-bit Red Hat Enterprise 6, 7 ・ 1 GHz 以上
・ 32-bit (x86)
4GB 4GB
32-bit SUSE 11, 12
32-bit Ubuntu 14.04 LTS, 14.10
64-bit Red Hat Enterprise 6, 7 ・ 1 GHz 以上
・ 64-bit (x64)
64-bit SUSE 11, 12
64-bit Ubuntu 14.04 LTS, 14.10

Maple 2015 の他ツールとのリンク機能

パッケージ名 他ツールバージョン
Microsoft® Excel® 2007, 2010, 2013 (Windows版) ※
MATLAB® R2013b / R2014a / R2014b / R2015a / R2015b
データベース SQLite または JDBC 準拠のデータベース
CAD SolidWorks® 2013 (Windows版)
Autodesk Inventor® 2014 または 2015 (Windows版)
NX® 8.5 または 9.0 (Windows版) + Microsoft .NET Framework

※Microsoft Excel 2007は32-bitアプリケーションのみ対応可能です。従って、Excel add-inを使用する為、32-bit Windows 版の Mapleをインストールする必要があります。64-bit Windows 版 Maple の場合は、Excel 2010 や Excel 2013 の Excel add-inのみ使用できます。

Maple 2015 アドオン製品 対応表

プロダクト名 必須ツール※
BlockImporter™ ・ Maple 2015
・ MATLAB® & Simulink® (※)
Global Optimization Toolbox Maple 2015
Maple IDE Maple 18 または Maple 2015 対応
Maple Player Maple 2015 本体は不要
Maple Player for iPad ・ iPad (iOS v4.3 以上)
・ Maple 2015 本体は不要
各アドオン製品の基本的な動作環境は Maple 2015 本体に準拠します。
※ MATLAB® 2013b / Simulink® 8.2
  MATLAB® 2014a / Simulink® 8.3
  MATLAB® 2014b / Simulink® 8.4
  MATLAB® 2015a / Simulink® 8.5
  MATLAB® 2015b / Simulink® 8.6

Maple 2015共通の注意点について

  • ※1 推奨メモリ以下でご利用になる場合、パフォーマンスが低下したり、使える機能が限定されることがあります。最小構成でご利用される場合はクラシックワークシートインターフェイスが推奨です。
  • DVD でインストールする際には、DVD-ROMドライブが必要です。
  • Mapleは実行中、内部でTCP/IPを使用します。従ってファイアウォールや同等の動作を行うソフトウェア(例:ウイルス対策ソフト等)を使用している場合、別途設定を行う必要があります。
  • Windows版とMacintosh版のみ日本語環境を提供しております。Linux版は英語環境でのみ提供しております。
  • 64bit版のWindowsをご利用の場合、Maple用のコンパイラを別途インストールする必要があります。Microsoft Visual Studio C++ 2013 および 2015 コンパイラがサポートされます。
  • クラシックワークシートはWindows 32bit, Linux 32bit OSでのみサポートされます。
  • 画面の設定について、画面の色を16-bit以上、画面の解像度を1024x768以上が推奨です。
  • 2D MathをMapleViewerでHTMLに出力する場合、出力されるHTMLを閲覧するため、下記が必要となります。
    • Java Runtime Environment 1.6.0_18 以降。
ご不明な点や詳細について、また上記リストに記載の無い動作環境につきましては、
テクニカルサポートへお問い合わせください。


お問い合わせ サイバネットシステム株式会社 システムCAE事業部
TEL: 03-5297-3255 (受付時間 9:00〜12:00 / 13:00〜17:30 ※土日祝及び弊社休業日を除く)
メールでのお問い合わせ  お問い合わせフォーム  お問い合わせ一覧

モデルベース開発